Der Cubietruck hat mich anfangs zu Verzweiflung gebracht. Als Arduino- und Raspberry-Profi hat mich der Cubietruck viele Stunden gekostet. Allein die Auswahl des richtigen Betriebssystem-Images und der Tools hat lange gedauert.

 

Die richtige SD-Card

Die Verwendung einer alten Class4-SD-Card hat Probleme bereitet. Das Betriebssystem-Image liess sich einwandfrei schreiben, aber der Cubietruck wollte nicht davon booten - er blieb einfach ohne Fehlermelldung hängen. Die Anschaffung einer Class10-Card hat diese Probleme behoben. Dieses Modell setze ich jetzt ein:

SanDisk Ultra microSDHC 8GB Class10-Speicherkarte 6,85€

 

Die richtige Stromversorgung

Mal wieder Bootprobleme gehabt. Das Board sprang an und die LED's gaben ein 2 Sekunden-Leuchtfeuer von sich, dann schaltete sich das Board aus. Das passierte beim Boot von NAND als auch von SD-Card. Ich habe ein 5V/2,5A-Netzteil eingesetzt, trotzdem Probleme. Die Ursache war ein Strommessmodul für USB zwischen Netzteil und Cubieboard. Hier liegt in der 5V-Versorgungsleitung ein kleiner Messwiderstand zur Strommessung. Die wenigen hundert Millivolt Spannungsabfall reichten aus, daß der Cubietruck nicht booten konnte. Adapter entfernt und alles funktioniert!

Fazit: Ein Netzteil mit ausreichend Stromabgabe verwenden, das keine Spannungseinbrüche hat.

 

Passwörter

Cubian

Benutzer: cubie
Passwort: cubie
SSH-port: 36000

 

Links

http://www.forum-cubieboard.de/Thread-cubian

http://www.forum-cubieboard.de/Thread-kernel-panic-bei-einbinden-und-booten-einer-sata-hdd?page=2

http://www.forum-cubieboard.de/Thread-cubietruck-bootet-nicht-vom-nand-cubian?page=2